View  Edit  Attributes  History  Attach  Print  Search

Ubuntu : Logiciels Utiles : Java

Liens utiles :

Sous Ubuntu 10.04 : activer le dépôt Partner pour pouvoir installer sun java (voir ci-dessous)

Installation

Pour faire fonctionner le logiciel Arduino ou Processing, qui rappelons-le sont écrits en Java, il faut que Java soit installé sur votre machine. On a le choix entre 2 versions principales qui correspondent aux paquets suivants :

  • soit le paquet sun-java6-jre (plateforme d'exécution des programmes Java) (libre à 95%)
  • soit le paquet openjdk-6-jre (totalement libre)
  • Personnellement, j'ai eu de gros problèmes d'affichage sous Ubuntu 10.04 en utilisant sun-java6-jre pourtant conseillé avec Processing (sic!), interface sur laquelle est basé Arduino. Je vous conseille donc d'utiliser openjdk qui est normalement installé par défaut sous Ubuntu 10.04.
  • modif : en fait le fameux "problème d'affichage" pourrait aussi provenir de Compiz qu'il faut désactiver si problème (Système > Préférences > Apparence > Effets > Aucun)
  • D'autre part, il semble qu'avec Processing, sun-java donne un meilleur résultat que openjdk en mode 2D... (Processing 1-5)

Pour installer les paquets :

  • soit suivre la procédure habituelle dans synaptic : sélectionner le paquet, clic droit et clic sur "sélectionner pour installation". Puis clic sur appliquer. Pour plus de détails, voir la page : Comment installer un paquet avec Synaptic
  • soit installer depuis la logithèque Ubuntu (chercher Java jre)

Note concernant la version de Java utilisée par défaut : Il se peut que plusieurs version de Java soient installées sur votre PC (openjDK et sun java). Pour être sûr que openjdk soit utilisé par défaut :

  • ouvrir une console et taper : sudo update-alternatives --config java
  • choisir le numéro correspondant à openjdk et valider.
  • relancer la même ligne de commande pour être sûr que la version par défaut a été modifiée.

Faire l'inverse si vous préférez utiliser sun java.

Pour plus de détails, voir : http://doc.ubuntu-fr.org/java

Sous Lucid (Ubuntu 10.04), les paquets de sun-java 6 sont disponibles dans le dépôt partenaire qu'il faut activer pour pouvoir l'installer. Remarque : vous pouvez aussi utiliser l'alternative icedtea6 (paquet icedtea-6-jre-cacao et son plugin pour les navigateurs web) Pour plus de détails, voir : http://doc.ubuntu-fr.org/java

Pour le dépôt partenaire : voir : http://doc.ubuntu-fr.org/depots#depot_partenaire_ou_depot_commercial En fait l'activation se fait simplement depuis Système > Sources Logiciels > onglet Autres Logiciels et cocher le lien "lucid partner"